Jump to content
Sign in to follow this  
MyCooky

[RESOLVED] Game crashes 2nd time I run it. (install directory problem)

Recommended Posts

After the install (of the new alpha 16) everything worked perfectly, but when I closed the game and restarted it,
the games crashes (I don't even get to the main menu).

I'm on windows 7 64 bit.

Any ideas what might cause this?

crashlog.txt

  • Like 1

Share this post


Link to post
Share on other sites

I played it on german, but even with english (I can open the game only after reinstalling) this still happens.

I tried unchecking everything in the options, but didn't seem to change much.

...But installing it to a new folder helped (dumb me), even with all the old settings :S.

What do you think could have been the problem?

Edited by MyCooky

Share this post


Link to post
Share on other sites

I think just the first one that was the default in the installer, don't know exactly what it was.

After changing directory everything works...

Share this post


Link to post
Share on other sites

It could be related to some special German characters in the directory. So it would be nice to know how those directories are called in German.

Share this post


Link to post
Share on other sites

The _ is quite common. And so is the 0. So I see absolutely no reason at all.

As it's fixed now, I don't think there's anything we can do about it. And lets hope you're the only one ;)

Share this post


Link to post
Share on other sites

Just to add some information to this,

I encountered the problem again today, but this time I noticed that there was another *pyrogenesis.exe* running in the background (without actually doing anything).

Also the \Appdata\Local\0ad folder was being used (by the pyrogenesis.exe).

So I think that's what caused the problem.

  • Like 1

Share this post


Link to post
Share on other sites

Hmm, sounds like it might have crashed in the background or have been slow to close. It can continue running if it's in a debug loop or if it's waiting for a background thread to finish. Maybe we need to check if an instance of pyrogenesis.exe is already running and warn the user before continuing the game startup (at least on Windows where this is most problematic)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...