Sign in to follow this  
Followers 0
mackan2

Hardware for high resolution?

7 posts in this topic

Hi.

I want to be able to play this game in 2560x1440. My current rig looks like:

core i7 860 @ 4x2.8GHz

8gb ram, 1600mhz

GeForce 210

Running Ubuntu 11.10, x64.

If I try to play now, I get extreme lag, even in the title screen. What kind of video card do I need? I'm looking for the cheapest option with good energy saving capabilities.

Share this post


Link to post
Share on other sites

The GeForce 210 only has 512mb of graphics memory. I would recommend for that size screen a card with double that (1GB of graphics RAM).

That said, the game is in Alpha still, and has various places it needs optimization. The path finder is slow, the AI is slow (so a 8 player game against AI is very slow).

So even with better hardware, you'd still get slowness. Might be best to try out the game in a lower res first, e.g. 1280x800.

Share this post


Link to post
Share on other sites

The AI is slow because each one keeps it's own entity list, data for where to build etc etc. They don't share, so an 8 qBot game will be 7x slower than a 1 qBot game.

Various components in it too could be sped up, like the AI finding what to harvest (i.e. is it reachable), where to build, among other things.

And path finding has been getting slower as more things get added to the game. Philip is already working on the path finder, but I don't know when it'll be finished.

1 person likes this

Share this post


Link to post
Share on other sites

Hi.

I want to be able to play this game in 2560x1440. My current rig looks like:

core i7 860 @ 4x2.8GHz

8gb ram, 1600mhz

GeForce 210

Running Ubuntu 11.10, x64.

If I try to play now, I get extreme lag, even in the title screen. What kind of video card do I need? I'm looking for the cheapest option with good energy saving capabilities.

I find it strange that you would have serious lag on the main menu.

Maybe it's a driver problem, which drivers do you have (the contents of system_info.txt can also be helpful)? What's your framerate (Alt-F) on the main menu?

Which version of the game are you using?

Share this post


Link to post
Share on other sites

OK, correction. Tried it again and there was no serious lag, this time. I guess I was running something in the background last time I tried it. But I'd like to tune up the graphics settings from default. I'l looking towards a nvidia gtx 560, so I guess that will work just fine?

Share this post


Link to post
Share on other sites

The Nvidia GTX 560 should do the trick.

Share this post


Link to post
Share on other sites

I think GF210 should be fine for 0 A.D. (even at highish resolutions), since we don't do anything graphically demanding - most slowdowns are due to the CPU, which will be fixed as we optimise the code. You probably need to make sure you're using the proprietary NVIDIA Linux drivers though, not the open source Nouveau drivers (which have various performance problems and general bugginess).

I have a GF560Ti, which is nice (it runs any modern game at nearly-highest settings without much trouble) and benchmarks seem to indicate it's about 10x as fast as the GF210, but I don't think it's cheap and it doesn't really have "good energy saving capabilities" (it's apparently >100W more than the GF210 when loaded), and it's certainly overkill for 0 A.D. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0