Jump to content
Sign in to follow this  
MishFTW

Packaged Mac App

Recommended Posts

Hi, just d/l'ed and played a bit on my mac. What an awesome game so far – brings back some fond AoE2 memories!

Just a couple of things that have probably been picked up before but just in case... During the game I couldn't use the menu button (it gets highlighted but doesn't open when I click) so I had to force quit to exit. Also was getting some javascript errors to do with 'jubot' when in combat. I've attached a screenshot of the error text from the console, sorry if there's a simpler way of submitting that info or if this is the wrong thread!

Great work folks!

post-14890-0-94453300-1347334150_thumb.p

Edited by shipteas

Share this post


Link to post
Share on other sites

<p><p>Hi, just d/l'ed and played a bit on my mac. What an awesome game so far – brings back some fond AoE2 memories!

Just a couple of things that have probably been picked up before but just in case... During the game I couldn't use the menu button (it gets highlighted but doesn't open when I click) so I had to force quit to exit. Also was getting some javascript errors to do with 'jubot' when in combat. I've attached a screenshot of the error text from the console, sorry if there's a simpler way of submitting that info or if this is the wrong thread! Great work folks!

Well the errors are expected, the game is still in alpha. Have you read this? It explains a lot :) Plus JuBot is pretty much deprecated and will probably be removed from the game by the next release.

Share this post


Link to post
Share on other sites

Yeah, I was expecting errors and such, just wanted to report them :)

With the menu button thing, it works when I'm using the discrete GPU (NVIDIA GeForce 9600m GT) but not when I'm using the integrated (NVIDIA GeForce 9400M).

Thanks for the link to the known problems thread – clears a lot up.

Share this post


Link to post
Share on other sites

During the game I couldn't use the menu button (it gets highlighted but doesn't open when I click) so I had to force quit to exit.

I have this as well, but repeatedly pressing the button sometimes works. Otherwise you can open the console (~, thus Shif+`) and type: exit(). That is easier than forced closing, and a quick way to exit the game completely.

Share this post


Link to post
Share on other sites

The bug should of course be fixed, but more out of curiosity: does F10 open the menu properly?

By default the f10 key on a mac keyboard disable the speaker. I think the the game must use ESC key to open the menu during the game.

Share this post


Link to post
Share on other sites

By default the f10 key on a mac keyboard disable the speaker. I think the the game must use ESC key to open the menu during the game.

:P Why do OSs have to use up single-key combinations (and especially for such ridiculous things :P ). Either way, using the ESC key is not a bad idea per se, but it does make it harder to enable the use of the ESC key to cancel dialogs. There is probably a way to do it though, and as always, you can customize the hotkeys (http://trac.wildfiregames.com/wiki/Manual_Settings ) for the time being.

Share this post


Link to post
Share on other sites

a little bit OT and just a wild guess about the single key thing:

the mac keyboard works similar to normal notebook keyboards with fn-functions but on the mac the multimedia functions are the default ones and the F1-F12 functions are shiftet with fn.

"Who would ever use such an old and unmagic thing like F-keys?!?!"You could use wild 5-finger multitouch gestures instead ;-)

Share this post


Link to post
Share on other sites

Upgraded to Lion on this old machine finally (its the highest this machine will go) and got Xcode 4. Should be able to build and distribute myself. If all goes well, I'll post SVN versions each week :)

Share this post


Link to post
Share on other sites

Upgraded to Lion on this old machine finally (its the highest this machine will go) and got Xcode 4. Should be able to build and distribute myself. If all goes well, I'll post SVN versions each week :)

Thanks, great idea. I will test your builds to comment it and submit OSX ML bugs (and Retina MBP bugs).

Share this post


Link to post
Share on other sites

Thanks, great idea. I will test your builds to comment it and submit OSX ML bugs (and Retina MBP bugs).

That reminds me, I want to try building on OS X against SDL 2.0 and see if it makes any difference.

Share this post


Link to post
Share on other sites

I am using these instructions. All was well until I entered the command cd gcc, just before the make command. I received a message saying "No such file or directory".

I'm using OSX 10.7.5 (Lion) and have Xcode 4.5.1 and the command line tools installed. I've tried using export CC=gcc CXX=g++ but it doesn't change anything. Any help?

Share this post


Link to post
Share on other sites

I am using these instructions. All was well until I entered the command cd gcc, just before the make command. I received a message saying "No such file or directory".

This folder ("gcc") should be generated inside "build/workspaces" (where you should be after "cd build/workspaces") by previous call ("./update-workspaces.sh --disable-atlas"). So if it was not, there is apparently some errors reported by update-workspaces, please paste its output here.

Share this post


Link to post
Share on other sites

Here you go...


iMac:~ Geek$ cd /Users/Geek/0ad
iMac:0ad Geek$ cd build/workspaces
iMac:workspaces Geek$ ./update-workspaces.sh --disable-atlas
readlink: illegal option -- f
usage: readlink [-n] [file ...]
Updating bundled third-party dependencies...
bash -c 'mkdir -p output/{debug,release,test}/{FCollada/{FCDocument,FMath,FUtils,FColladaTest/{FCTestAssetManagement,FCTestExportImport,FCTestXRef}},FColladaPlugins/FArchiveXML}'
cp output/libFColladaSD.a ../lib/libFColladaSD.a
cp output/libFColladaSR.a ../lib/libFColladaSR.a
Building SpiderMonkey...
SpiderMonkey build options: --disable-tests
patching file js-1.8.5/js/src/configure.in
patching file js-1.8.5/js/src/configure
patching file js-1.8.5/js/src/jsnativestack.cpp
loading cache ./config.cache
checking host system type... x86_64-apple-darwin11.4.2
checking target system type... x86_64-apple-darwin11.4.2
checking build system type... x86_64-apple-darwin11.4.2
checking for mawk... no
checking for gawk... no
checking for nawk... no
checking for awk... awk
checking for perl5... no
checking for perl... /usr/bin/perl
checking for gcc... gcc-4.2
checking whether the C compiler (gcc-4.2 ) works... no
configure: error: installation or configuration problem: C compiler cannot create executables.
ERROR: SpiderMonkey build failed
iMac:workspaces Geek$ cd gcc
-bash: cd: gcc: No such file or directory
iMac:workspaces Geek$

Share this post


Link to post
Share on other sites

Do the gcc/g++ commands exist? Try "which gcc" and see if it gives you a path. At least for my version of Xcode and command line tools, gcc does exist, but it's only a symlink to llvm-gcc-4.2. Spidermonkey is incorrectly configured to use "gcc-4.2" which doesn't exist anymore on OS X, so it fails (this is why it must be overriden by CC and CXX).

This might work: "export CC=llvm-gcc-4.2 CXX=llvm-g++-4.2" before running update-workspaces.

Share this post


Link to post
Share on other sites

Do the gcc/g++ commands exist? Try "which gcc" and see if it gives you a path. At least for my version of Xcode and command line tools, gcc does exist, but it's only a symlink to llvm-gcc-4.2. Spidermonkey is incorrectly configured to use "gcc-4.2" which doesn't exist anymore on OS X, so it fails (this is why it must be overriden by CC and CXX).

This might work: "export CC=llvm-gcc-4.2 CXX=llvm-g++-4.2" before running update-workspaces.

It worked. I compiled the game and ran the test and everything went well. Until I started a match; the models won't load. -_-

Share this post


Link to post
Share on other sites

I think it's a path issue. I've had the very same issue with the collada lib, and changing the DLLLoader.cpp file (in source/ps) from

#if OS_UNIX
static CStr prefix = "lib";
#else
static CStr prefix = "";
#endif

to

#if OS_MACOSX
static CStr prefix = "@executable_path/lib";
#elif OS_UNIX
static CStr prefix = "lib";
#else
static CStr prefix = "";
#endif

made it load properly. However, the collada library must be put in the same folder as the executable (in the current repo architecture, it should be that way. If it's a packaged app however, the path may need to be changed. As I understand it, Geek, you're trying to compile the project created by update-workspaces, so you should only have to apply the change I just wrote).

Share this post


Link to post
Share on other sites

Does Atlas work without that change? If Atlas works, then I don't see why Collada wouldn't work, since they are in the same location. Of course if Atlas fails to open too, then that may be the best solution. If one works and one doesn't, it sounds more like an issue with our Premake script (but what?).

According to Apple's documentation for dlopen:

The dynamic loader looks in the paths specified by a set of environment variables, and in the process’s current directory, when it searches for a library. These paths are called dynamic loader search paths. The environment variables are LD_LIBRARY_PATH, DYLD_LIBRARY_PATH, and DYLD_FALLBACK_LIBRARY_PATH. The default value of DYLD_FALLBACK_LIBRARY_PATH (used when this variable is not set), is $HOME/lib;/usr/local/lib;/usr/lib.

The order in which the search paths are searched depends on whether path is a filename (it does not contain a slash) or a pathname (it contains at least one slash).

When path is a filename, the dynamic loader searches for the library in the search paths in the following order:

1. $LD_LIBRARY_PATH

2. $DYLD_LIBRARY_PATH

3. The process’s working directory

4. $DYLD_FALLBACK_LIBRARY_PATH

The working directory should be binaries/system? You might be able to use lsof to find out the cwd, like "lsof -a -d cwd -c pyrogenesis".

Share this post


Link to post
Share on other sites

The working directory should be binaries/system? You might be able to use lsof to find out the cwd, like "lsof -a -d cwd -c pyrogenesis".

The libraries and dylibs are present in binaries/system. I used Wraitii's changes and it works :)

Share this post


Link to post
Share on other sites

Can you try that lsof command and see what pyrogenesis' working directory is?

I just got a bunch of system info when I ran lsof but nothing about pyrogenesis. I also ran

lsof -a -d cwd -c pyrogenesis

but didn't produce any results.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×