Sign in to follow this  
Followers 0
Louis_marie_c

ERROR: FCollada build failed

29 posts in this topic

Well this seems to have solved the problem, but impossible to launch the application 0ADcrash at launch (to be precise in fact it does not start at all)



Process: test [66892]
Path: /Users/USER/*/test.app/Contents/MacOS/test
Identifier: test
Version: ??? (???)
Code Type: X86-64 (Native)
Parent Process: launchd [222]

Date/Time: 2012-01-04 01:38:43.728 +0100
OS Version: Mac OS X 10.7.2 (11C74)
Report Version: 9
Sleep/Wake UUID: 055D04A1-523A-46D7-9759-30DC386A8A37

Interval Since Last Report: 72370 sec
Crashes Since Last Report: -23
Per-App Crashes Since Last Report: 2
Anonymous UUID: 14[******]

Crashed Thread: 0

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Library not loaded: @executable_path/libmozjs185-ps-release.1.0.dylib
Referenced from: /Users/USER/*/test.app/Contents/MacOS/test
Reason: image not found

Binary Images:
0x101160000 - 0x1016e4fe7 +test (??? - ???) <1D9DC03C-1E6C-3072-BBEE-CEAC8ACB86B9> /Users/USER/*/test.app/Contents/MacOS/test
0x101a7d000 - 0x101aa8fff com.apple.audio.OpenAL (1.5.1 - 1.5.1) <5B954EC6-08B6-3255-932C-DDAB908E72F4> /System/Library/Frameworks/OpenAL.framework/Versions/A/OpenAL
0x101abe000 - 0x101af2fe7 +libjpeg.8.dylib (12.0.0 - compatibility 12.0.0) <91678CF3-F9A9-3A56-A2E8-32B503616BA9> /opt/local/lib/libjpeg.8.dylib
0x101afd000 - 0x101b1cfff +libpng15.15.dylib (20.0.0 - compatibility 20.0.0) <48C87023-FB13-393C-8FD4-DE4F1803ECA3> /usr/X11/lib/libpng15.15.dylib
0x101b2b000 - 0x101b3efff +libz.1.dylib (1.2.5 - compatibility 1.0.0) <FE5409A4-0190-3939-9A83-9CF4BEFAEA0C> /opt/local/lib/libz.1.dylib
0x7fff60d60000 - 0x7fff60d94ac7 dyld (195.5 - ???) <4A6E2B28-C7A2-3528-ADB7-4076B9836041> /usr/lib/dyld
0x7fff8ab0f000 - 0x7fff8ab1eff7 com.apple.opengl (1.7.5 - 1.7.5) <2945F1A6-910C-3596-9988-5701B04BD821> /System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL

Model: MacBookPro5,1, BootROM MBP51.007E.B05, 2 processors, Intel Core 2 Duo, 2.53 GHz, 4 GB, SMC 1.33f8
Graphics: NVIDIA GeForce 9600M GT, NVIDIA GeForce 9600M GT, PCIe, 512 MB
Graphics: NVIDIA GeForce 9400M, NVIDIA GeForce 9400M, PCI, 256 MB
Memory Module: BANK 0/DIMM0, 2 GB, DDR3, 1067 MHz, 0x80CE, 0x4D34373142353637334448312D4346382020
Memory Module: BANK 0/DIMM1, 2 GB, DDR3, 1067 MHz, 0x80CE, 0x4D34373142353637334448312D4346382020
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8D), Broadcom BCM43xx 1.0 (5.100.98.75.18)
Bluetooth: Version 4.0.1f4, 2 service, 11 devices, 1 incoming serial ports
Network Service: Ethernet, Ethernet, en0
Serial ATA Device: Hitachi HTS723232L9SA62, 320,07 GB
Serial ATA Device: MATSHITADVD-R UJ-868
USB Device: SAMSUNG_Android, 0x04e8 (Samsung Electronics Co., Ltd.), 0x681c, 0x24100000 / 3
USB Device: Built-in iSight, apple_vendor_id, 0x8507, 0x24400000 / 2
USB Device: BRCM2046 Hub, 0x0a5c (Broadcom Corp.), 0x4500, 0x06100000 / 2
USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8213, 0x06110000 / 3
USB Device: IR Receiver, apple_vendor_id, 0x8242, 0x04500000 / 3
USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0237, 0x04600000 / 2

Edited by Louis_marie_c

Share this post


Link to post
Share on other sites

Well this seems to have solved the problem, but impossible to launch the application 0ADcrash at launch (to be precise in fact it does not start at all)



Process: test [66892]
Path: /Users/USER/*/test.app/Contents/MacOS/test
....

Library not loaded: @executable_path/libmozjs185-ps-release.1.0.dylib
Referenced from: /Users/USER/*/test.app/Contents/MacOS/test
Reason: image not found
...

That looks much better :).

You should run pyrogenesis.app instead of test.app... but this one will crash too because it won't be able to find a few libraries like libmozjs185-ps-release.1.0.dylib.

That's a know problem and the easiest way for you to solve it is copying the binary (pyrogenesis) out of pyrogenesis.app directly to 0ad/binaries/system/ and running it from there.

Share this post


Link to post
Share on other sites

That looks much better :).

You should run pyrogenesis.app instead of test.app... but this one will crash too because it won't be able to find a few libraries like libmozjs185-ps-release.1.0.dylib.

That's a know problem and the easiest way for you to solve it is copying the binary (pyrogenesis) out of pyrogenesis.app directly to 0ad/binaries/system/ and running it from there.

oddly the application weighs only 7.5Mo 0o

To compile a Mac .app bundle cleanly, could you please try: http://trac.wildfire...t/947#comment:2

Importantly, you still need to copy the contents of the binaries/ directory from SVN *into* your .app bundle under data/.

I don't understand all the things to do. Inside the app i've only one folder named contents thats all could you give me more information about how to thanks blush.gif

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0