Sign in to follow this  
Followers 0
cc_julian

precompiled mac version done

105 posts in this topic

I've got a version of the Alpha 8 that should be deployable for Mac os X. It works on 10.6 and 10.7 on the two computers I tried at home, and it should have no particular dependencies other than OpenAl, OpenGL and the basic libraries that come with OSX. If anybody can report, download it here. It should work, but I can't guarantee it 100%. At least it worked on the computer where I went through the whole "compiling", and on another computer which is basically "vanilla".

Btw, I encountered few compilation problems, mainly linking problems. In fact, using dynamic libraries on OSX is a real pain, there needs to be copying and script running. I have not included the source in this file, but I can tell you how to fix the Xcode Project for the most part. It's basically allright, but there are a few things to fix here and there, and libraries are a -real- pain.

Thing is, a shell script that downloads every library necessary and puts them in the right folders could really straighten out the installing process on Mac OS X, but I think my knowledge is a bit lacking on the matter.

Edited by wraitii

Share this post


Link to post
Share on other sites

I've got a version of the Alpha 9 that should be deployable for Mac os X. It works on 10.6 and 10.7 on the two computers I tried at home, and it should have no particular dependencies other than OpenAl, OpenGL and the basic libraries that come with OSX. If anybody can report, download it here. It should work, but I can't guarantee it 100%. At least it worked on the computer where I went through the whole "compiling", and on another computer which is basically "vanilla".

Btw, I encountered few compilation problems, mainly linking problems. In fact, using dynamic libraries on OSX is a real pain, there needs to be copying and script running. I have not included the source in this file, but I can tell you how to fix the Xcode Project for the most part. It's basically allright, but there are a few things to fix here and there, and libraries are a -real- pain.

Thing is, a shell script that downloads every library necessary and puts them in the right folders could really straighten out the installing process on Mac OS X, but I think my knowledge is a bit lacking on the matter.

I don't have a OS X so I can't test but if it works that would be great. Good work.

Share this post


Link to post
Share on other sites

Darn, I wrote Alpha 9, I'm getting a bit carried away.

I didn't really troubleshoot this, so it's likely fairly buggy even if it starts but i uploaded it to see... I'm going to release my source code tomorrow, which will hopefully be more useful.

edit: apparently the Collada problem that was encountered with the former version still happens on Lion... I'd like to know if anybody can confirm or infirm.

Edited by wraitii

Share this post


Link to post
Share on other sites

I'm going to release my source code tomorrow, which will hopefully be more useful.

When you upload the Xcode project file I'll take a look. Thanks.

Share this post


Link to post
Share on other sites

I'm straightening it out and then uploading. I think I won't upload the data to save space, nor the compiled app, so you'll have to put it in the right folder, I'll indicate which.

Edit: Okay... Still trying to get the raw minimum, but at the very least I fixed the Collada issue. In fact, because it's loaded at runtime, the game couldn't find the dylib. I've added a little fix in "DLLloader.cpp" which should not conflict ( I used a "IFDEF mac os X") which solves the issue, you'll see when I'm over.

Edited by wraitii

Share this post


Link to post
Share on other sites

Okay, so this is the basic core of my Xcode project. It's not brand new, it's only an improved version of the workspaces that the game creates when following the instructions on the wiki.

You'll need two things, I think: the data (downloadable here) and the "libraries" folder, with compiled libraries. I have included the basic one, but I don't think it'll work with it... So you might have to go though the "normal" installation process as described on the wiki once, and then replace the files with mine (but the "libraries" folder). (Note that I have included a "Libraries" folder in /system , this one is not the one I'm talking about. I'm talking about the one in the root folder.)

Download link,

If you're having any trouble, please report.

This includes the fixed Collada thing, but Atlas doesn't work. I'm compressing a new "precompiled" executable and am going to upload it later today, this one should actually be deployable.

Edited by wraitii

Share this post


Link to post
Share on other sites

somehow i cant find a open GL Version... i think it should be open GL 2.1. for Snow Leopard?

do i have to unzip the data.zip in the which is in the mods/public/... folder?

... and it crashes till now:

Process: 0A.D. [553]

Path: /Users/xxxxxxxxx/Downloads/0 A.D./data/0A.D..app/Contents/MacOS/0A.D.

Identifier: 0A.D.

Version: ??? (???)

Code Type: X86-64 (Native)

Parent Process: launchd [96]

Date/Time: 2011-12-25 12:06:17.966 +0100

OS Version: Mac OS X 10.6.8 (10K549)

Report Version: 6

Interval Since Last Report: 768089 sec

Crashes Since Last Report: 15

Per-App Crashes Since Last Report: 4

Anonymous UUID: 8DC3718B-399A-4E24-84E3-54B17EFB45E1

Exception Type: EXC_BREAKPOINT (SIGTRAP)

Exception Codes: 0x0000000000000002, 0x0000000000000000

Crashed Thread: 0

Dyld Error Message:

Library not loaded: /usr/X11/lib/libpng12.0.dylib

Referenced from: /Users/xxxxxxxxxxx/Downloads/0 A.D./data/0A.D..app/Contents/MacOS/../Frameworks/libnvimage.dylib

Reason: Incompatible library version: libnvimage.dylib requires version 47.0.0 or later, but libpng12.0.dylib provides version 45.0.0

Binary Images:

0x7fff5fc00000 - 0x7fff5fc3be0f dyld 132.1 (???) <29DECB19-0193-2575-D838-CF743F0400B2> /usr/lib/dyld

do you have any idea???

but nevertheless... cool that you uploaded a version... great!

warm regards!

Share this post


Link to post
Share on other sites

No, afaik the Data should be kept zipped (but the developers will answer that better)...

That's a weird problem, it looks like you have an outdated version of libpng in your X11 folder... I suggest you download the latest version of X11 and retry.

OpenGL should already be in your HD/Library/Frameworks.

You're likely trying to use the former version of my precompiled 0A.D. , which has bugs with Collada and some libraries, I'm uploading a newer one which should work independently.

edit: Okay, try replacing the application (only the application) by this one. Normally, you don't even have to update X11 as this version should rely on the one bundled with it (which means that it should simply work).

Edited by wraitii

Share this post


Link to post
Share on other sites

No, afaik the Data should be kept zipped (but the developers will answer that better)...

That's a weird problem, it looks like you have an outdated version of libpng in your X11 folder... I suggest you download the latest version of X11 and retry.

OpenGL should already be in your HD/Library/Frameworks.

You're likely trying to use the former version of my precompiled 0A.D. , which has bugs with Collada and some libraries, I'm uploading a newer one which should work independently.

edit: Okay, try replacing the application (only the application) by this one. Normally, you don't even have to update X11 as this version should rely on the one bundled with it (which means that it should simply work).

ok... cool, thankyou so much for the fast answer.

downloading...

will report immediately...

merry christmas by the way ... if you're belonging to that cultural hemisphere ;)

Share this post


Link to post
Share on other sites

Process: 0A.D. [603]

Path: /Users/xxxxxxx/Downloads/0 A.D./data/0A.D..app/Contents/MacOS/0A.D.

Identifier: 0A.D.

Version: ??? (???)

Code Type: X86-64 (Native)

Parent Process: launchd [96]

Date/Time: 2011-12-25 12:33:18.406 +0100

OS Version: Mac OS X 10.6.8 (10K549)

Report Version: 6

Interval Since Last Report: 769708 sec

Crashes Since Last Report: 16

Per-App Crashes Since Last Report: 5

Anonymous UUID: 8DC3718B-399A-4E24-84E3-54B17EFB45E1

Exception Type: EXC_BREAKPOINT (SIGTRAP)

Exception Codes: 0x0000000000000002, 0x0000000000000000

Crashed Thread: 0

Dyld Error Message:

Library not loaded: /opt/local/lib/libjpeg.8.dylib

Referenced from: /Users/xxxxxx/Downloads/0 A.D./data/0A.D..app/Contents/MacOS/0A.D.

Reason: image not found

Binary Images:

0x7fff5fc00000 - 0x7fff5fc3be0f dyld 132.1 (???) <29DECB19-0193-2575-D838-CF743F0400B2> /usr/lib/dyld

hmmmm... any idea? where can i find a x11 version... couldn't find one, as well as i dont see an open GL version in my frameworks-folder

i am using snow leopard on a 2011 iMac...

Share this post


Link to post
Share on other sites

Hmmm. Shouldn't do that...

I'm actually going to have Christmas now, so I won't be able to update for a few hours. Merry Christmas all.

I get it... There's indeed a problem, I'll fix it as soon as possible

Edited by wraitii

Share this post


Link to post
Share on other sites

We need to upgrade the premake to latest version, there are some patches to support xcode4 (fixes a regression)

Share this post


Link to post
Share on other sites

Can anybody try this version? I'm not sure which it is, but it should fairly work.

Doesn't work with Snow Leopard 10.6.8, try to create a window but the app closes throwing a window with error messages.

Share this post


Link to post
Share on other sites

Doesn't work with Snow Leopard 10.6.8, try to create a window but the app closes throwing a window with error messages.

Could you "report the problem to Apple" and paste the error code?

And have you downloaded the data? If not, download the data, and put the application in the same folder as the "mods", "config" and "tools" folder.

In case there is still a problem and it appears you have done everything right, could you open the console and paste the error messages appearing?

Edited by wraitii

Share this post


Link to post
Share on other sites

but unfortunately atlas does not work, although according to the developers-team it should.

in the "suggestions for 0 A.D."-thread they say it would need some extra tweaking concerning the compiling.

hmmm?!

Share this post


Link to post
Share on other sites

Yeah, I didn't include AtlasUI.dylib because I couldn't get it to compile, but I didn't really try either because I focused myself on getting the game to work first.

Share this post


Link to post
Share on other sites

Yeah, I didn't include AtlasUI.dylib because I couldn't get it to compile, but I didn't really try either because I focused myself on getting the game to work first.

You are doing a great work. I suggest Wildfire Games create another pledgie to contribute to paid a couple of developers to adapt knowadays code to create Mac binaries for Snow Leopard and Lion. We are in 8 Alpha version and still without an stable Mac version.

Share this post


Link to post
Share on other sites

We are in 8 Alpha version and still without an stable Mac version.

lol! Alpha! "Alpha"!!! :D

Share this post


Link to post
Share on other sites

Tried it out on OSX 10.7, no luck...put the file in the 3 folders you said then tried running it, and it opened a blank window, then crashed...is the error report helpful? not sure which part to post if it is..it's huge compared to the ones in the last page.

Share this post


Link to post
Share on other sites

We need to upgrade the premake to latest version, there are some patches to support xcode4 (fixes a regression)

We are currently using premake 4.3 with a lot of customizations.

Premake 4.4 is in Beta-state and as far as I've seen, they have changed quite a lot of the internal structure.

When I began working on the upgrade from premake3.x to premake4.3, I thought it would be much easier to upgrade to newer versions once it's finished.

It will be easier, but unfortunately there was no way around making changes to premake itself which will make an upgrade harder than initially expected.

Hopefully some of the errors I had to fix in 4.3 will be already fixed in 4.4 and all the assembler stuff isn't needed anymore, but maybe there will be new bugs or changes that require adaptation.

I will probably have another look a it after premake4.4 is stable. This time it's probably better to take the time and try to get as much of our changes back into premake so that the next upgrade will be easier.

In regard of xcode support, we can't expect the upgrade to happen in the next few months and I don't even know if premake4.4 supports it much better.

On the other hand, XCode support isn't directly connected to supporting .app bundles in our build-process.

We could already do it now if there was someone with a Mac and enough knowledge and time.

I used a VM for the Premake development, but that's not sufficient for this task and current I'm not willing to pay hundreds of dollars just for this purpose.

Maybe I could buy a Macbook and set up a dualboot with linux... so I could also use it for other purposes. :)

Share this post


Link to post
Share on other sites

Tried it out on OSX 10.7, no luck...put the file in the 3 folders you said then tried running it, and it opened a blank window, then crashed...is the error report helpful? not sure which part to post if it is..it's huge compared to the ones in the last page.

It should be helpful anyway.

I'm not sure which version I've posted where, but this is the latest version. Just download it and start the application without changing anything, it ought to work.

Share this post


Link to post
Share on other sites

It should be helpful anyway.

I'm not sure which version I've posted where, but this is the latest version. Just download it and start the application without changing anything, it ought to work.

Great work. All the content in a folder. Works on Snow Leopard 10.6.8 but when you launch the game i can see many lines with errors and the game start to works slowly.

Unique great problem, game has no sound(no background music and no sound effect).

Detail needed: nice icon.

But also great work, it goes on the right way.

Edited by memmaker650

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0